I suggest you...

Create a Timeout Config to LoadBalancers

I am very frustrated with the operation of the LoadBalancer. I have web services that lead to 2 minutes to answer a call and load balancer timeout is only 30 seconds and can not be changed. This behavior of the load balancer should only redirect calls to the servers, does not reproduce the actual operation of the server timeout is configurable. I put my clients to use loadbalance and started to have problems. At least this limitation had to be explicit in the description of the service so I would avoid spending so much time trying to identify the problem.
The suggestion of a support is that I create my own load balancer not what I believe to be the best answer.

Thanks

114 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Marcello PazMarcello Paz shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    completed  ·  Tom CreightonAdminTom Creighton (Admin, Rackspace) responded  · 

    The timeout feature is currently available in the CLB API with a default of 30 seconds and a maximum configurable value of 120 seconds. For this reason, I am marking this feature as complete. However, if you feel that this feature should be available in the control panel or should have a different maximum timeout value, please create a new feedback item so that it can be independently tracked and prioritized.

    I have included a link to the API documentation.

    http://docs.rackspace.com/loadbalancers/api/v1.0/clb-devguide/content/Update_Load_Balancer_Attributes-d1e1812.html

    Kind regards,

    8 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Robert NavarroRobert Navarro commented  ·   ·  Flag as inappropriate

        Looking at the API docs it looks like there is an upper limit of 2 minutes for a timeout....is there a way we can make this higher?

      • Nigel StreetNigel Street commented  ·   ·  Flag as inappropriate

        I assume the control panel option will also be available for Load Balancers associated with a Cloud Server? If not, please add that to the requirements :-)

      • IsaacIsaac commented  ·   ·  Flag as inappropriate

        Can I setup unlimited timeouts now? Where can I read the documentation?

      • Marbot FlorentMarbot Florent commented  ·   ·  Flag as inappropriate

        Yes it kills all main CMS usage, wordpress, drupal...
        Cloudsites loses one of the last good point it still have...

      • SamSam commented  ·   ·  Flag as inappropriate

        No solution, only a second I'm afraid. I am having a similar issue, an (admittedly slow) page times out rather than waiting. This makes previously slow operations unusable. Not good.
        I moved to the balancer service from my own balancer (heartbeat / haproxy) to reduce work, not increase it.

      Feedback and Knowledge Base

      ©2014 Rackspace, US Inc. About Rackspace | Fanatical Support® | Hosting Solutions | Investors | Careers | Privacy Statement | Website Terms | Sitemap